Skip to content

← Actionable
Medium, CVSS 4.3amended

Cross-site Scripting and Open Redirect in Products.CMFPlone

GHSA-8w54-22w9-3g8f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (products-cmfplone 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Plone is vulnerable to reflected cross site scripting and open redirect when an attacker can get a compromised version of the imageviewfullscreen page in a cache, for example in Varnish. The technique is known as cache poisoning. Any later visitor can get redirected when clicking on a link on this page. Usually only anonymous users are affected, but this depends on your cache settings. Patches No patch is available for the Products.CMFPlone 4 series. Versions 5.0 and higher are not affected, but two other packages used by these versions are affected. plone.app.contenttypes has the same problem in all versions, see advisory. In Plone 5.0-5.2, the default Products.ATContentTypes version has the same problem. See advisory. Plone 5.2.7 and 6.0.0a3 will be released today and will include these fixes. For all unpatched versions of the three packages, you can use the following workaround. Workaround Make sure the imageviewfullscreen page is not stored in the cache. In Plone: Login as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8w54-22w9-3g8f

  2. Revision 1 · created ·

    Published from osv record GHSA-8w54-22w9-3g8f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8w54-22w9-3g8f

Advisory: Cross-site Scripting and Open Redirect in Products.CMFPlone
IDs: GHSA-8w54-22w9-3g8f
Record: https://patchnext.com/advisories/ghsa-8w54-22w9-3g8f (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: products-cmfplone 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI products-cmfplone: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show products-cmfplone`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on products-cmfplone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8w54-22w9-3g8f (OSV record GHSA-8w54-22w9-3g8f lists affected ranges: PyPI products-cmfplone >=0 <5.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8w54-22w9-3g8f (GitHub-reviewed advisory GHSA-8w54-22w9-3g8f lists affected ranges: PyPI products-cmfplone >=0 <5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…