devalue unevaled code can create objects with polluted prototypes when evaled
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm devalue
- Affected
- <= 5.6.2
- Fixed in
- 5.6.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8qm3-746x-r74r lists affected ranges: npm devalue >=0 <5.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qm3-746x-r74r lists affected ranges: npm devalue >=0 <=5.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Under certain circumstances, unevaling untrusted data can produce output code that will create objects with polluted prototypes when later evaled, meaning the output data can be a different shape from the input data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8qm3-746x-r74r
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8qm3-746x-r74r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-8qm3-746x-r74r Advisory: devalue `uneval`ed code can create objects with polluted prototypes when `eval`ed IDs: GHSA-8qm3-746x-r74r Record: https://patchnext.com/advisories/ghsa-8qm3-746x-r74r (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devalue 5.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm devalue: affected <= 5.6.2; fixed in 5.6.3 ## Suggested inspection (read-only) - `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devalue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8qm3-746x-r74r (OSV record GHSA-8qm3-746x-r74r lists affected ranges: npm devalue >=0 <5.6.3 (fixed)) - Verified: https://github.com/advisories/GHSA-8qm3-746x-r74r (GitHub-reviewed advisory GHSA-8qm3-746x-r74r lists affected ranges: npm devalue >=0 <=5.6.2) Commands are suggestions: review each one before running it.
Loading voting…