ogham-mcp had credentials embedded in published PyPI sdists -- Neon postgres URLs and Voyage API key
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ogham-mcp 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ogham-mcp
- Affected
- >= 0.6.3, < 0.11.1
- Fixed in
- 0.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8pqq-224h-x875 lists affected ranges: PyPI ogham-mcp >=0.6.3 <0.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8pqq-224h-x875 lists affected ranges: PyPI ogham-mcp >=0.6.3 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Between 2026-02 and 2026-04-24 a total of 22 public PyPI sdists of ogham-mcp contained development credentials embedded in source files. All credentials have since been rotated on the respective providers. No known exploitation. Upgrade to v0.11.1 to get a clean release. What was leaked | Credential | Location in sdist | Vulnerable range | Count | |---|---|---|---| | 3x Neon postgres URLs with passwords (US / EU / AP development databases) | top-level Makefile (NEONUS, NEONEU, NEONAP vars) | =0.6.5, <0.11.0 | 21 sdists | | 1x Voyage AI API key (pa-...) | tests/testhooks.py::testmasksecretskeyvalue -- test fixture that fed a real key into the redaction-function tester | =0.6.3, <0.11.1 | 22 sdists | Impact - Primary risk: any consumer of the affected sdists could have extracted the credentials and used them. The Neon URLs pointed at development databases; the Voyage key was a rate-limited API key. - Observed exploitation: none detected. Audit logs on both providers were…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8pqq-224h-x875
- Revision 1 · created ·
Published from osv record GHSA-8pqq-224h-x875
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-8pqq-224h-x875 Advisory: ogham-mcp had credentials embedded in published PyPI sdists -- Neon postgres URLs and Voyage API key IDs: GHSA-8pqq-224h-x875 Record: https://patchnext.com/advisories/ghsa-8pqq-224h-x875 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ogham-mcp 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ogham-mcp: affected >= 0.6.3, < 0.11.1; fixed in 0.11.1 ## Suggested inspection (read-only) - `python -m pip show ogham-mcp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ogham-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8pqq-224h-x875 (OSV record GHSA-8pqq-224h-x875 lists affected ranges: PyPI ogham-mcp >=0.6.3 <0.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-8pqq-224h-x875 (GitHub-reviewed advisory GHSA-8pqq-224h-x875 lists affected ranges: PyPI ogham-mcp >=0.6.3 <0.11.1) Commands are suggestions: review each one before running it.
Loading voting…