rPGP affected by crash in message handling for deeply nested messages
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgp 0.19.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io pgp
- Affected
- >= 0.16.0-alpha.0, < 0.19.0
- Fixed in
- 0.19.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8h58-w33p-wq3g lists affected ranges: crates.io pgp >=0.16.0-alpha.0 <0.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Previous rPGP versions could be caused to crash with a "stack overflow" when parsing messages that contain deeply nested message layers, such as messages with many signatures. rPGP 0.19.0 resolves this issue with a more robust message handling implementation (via https://github.com/rpgp/rpgp/pull/625). Impact An attacker could cause applications to crash in rPGP's message parsing subsystem, when applications attempt to ingest messages. Attribution Discovered internally during rPGP development, using a fuzz test suite previously contributed by Christian Reitter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8h58-w33p-wq3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-8h58-w33p-wq3g Advisory: rPGP affected by crash in message handling for deeply nested messages IDs: GHSA-8h58-w33p-wq3g Record: https://patchnext.com/advisories/ghsa-8h58-w33p-wq3g (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pgp 0.19.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io pgp: affected >= 0.16.0-alpha.0, < 0.19.0; fixed in 0.19.0 ## Suggested inspection (read-only) - crates.io pgp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pgp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8h58-w33p-wq3g (GitHub-reviewed advisory GHSA-8h58-w33p-wq3g lists affected ranges: crates.io pgp >=0.16.0-alpha.0 <0.19.0) Commands are suggestions: review each one before running it.
Loading voting…