Skip to content

← Actionable
High, CVSS 8.8

TYPO3 Arbitrary Code Execution via File List Module

GHSA-8h4m-r4wm-xj7r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms 9.5.4, 8.7.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms

    Affected
    >= 8.0.0, < 8.7.23>= 9.0.0, < 9.5.4
    Fixed in
    8.7.23, 9.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Due to missing file extensions in $GLOBALS['TYPO3CONFVARS']['BE'][‘fileDenyPattern’], backend users are allowed to upload .phar, .shtml, .pl or .cgi files which can be executed in certain web server setups. A valid backend user account is needed in order to exploit this vulnerability. Derivatives of Debian GNU Linux are handling .phar files as PHP applications since PHP 7.1 (for unofficial packages) and PHP 7.2 (for official packages). The file extension .shtml is bound to server side includes which are not enabled per default in most common Linux based distributions. File extension .pl and .cgi require additional handlers to be configured which is also not the case in most common distributions (except for /cgi-bin/ location).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8h4m-r4wm-xj7r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8h4m-r4wm-xj7r

Advisory: TYPO3 Arbitrary Code Execution via File List Module
IDs: GHSA-8h4m-r4wm-xj7r
Record: https://patchnext.com/advisories/ghsa-8h4m-r4wm-xj7r (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms 9.5.4, 8.7.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms: affected >= 8.0.0, < 8.7.23; >= 9.0.0, < 9.5.4; fixed in 8.7.23, 9.5.4

## Suggested inspection (read-only)
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8h4m-r4wm-xj7r (GitHub-reviewed advisory GHSA-8h4m-r4wm-xj7r lists affected ranges: Packagist typo3/cms >=8.0.0 =9.0.0 <9.5.4)

Commands are suggestions: review each one before running it.

Loading voting…