Skip to content

← Actionable
Unratedamended

Taylored webhook validation vulnerabilities

GHSA-8g98-m4j9-qww5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (taylored 7.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm taylored

    Affected
    >= 7.0.5, < 7.0.8
    Fixed in
    7.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Critical Security Advisory for Taylored npm package v7.0.7 - tag 7.0.5 Summary A series of moderate to high-severity security vulnerabilities have been identified specifically in version 7.0.7 of \taylored\. These vulnerabilities reside in the "Backend-in-a-Box" template distributed with this version. They could allow a malicious actor to read arbitrary files from the server, download paid patches without completing a valid purchase, and weaken the protection of encrypted patches. All users who have installed or generated a \taysell-server\ using version 7.0.7 of \taylored\ are strongly advised to immediately upgrade to version 7.0.8 (or later) and follow the required mitigation steps outlined below. Versions prior to 7.0.7 did not include the Taysell functionality and are therefore not affected by these specific issues. Vulnerabilities Patched in v7.0.8 Version 7.0.8 addresses the following issues found in the v7.0.7 template: 1. Path Traversal in Patch Download: The patch download…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8g98-m4j9-qww5

  2. Revision 1 · created ·

    Published from osv record GHSA-8g98-m4j9-qww5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8g98-m4j9-qww5

Advisory: Taylored webhook validation vulnerabilities
IDs: GHSA-8g98-m4j9-qww5
Record: https://patchnext.com/advisories/ghsa-8g98-m4j9-qww5 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: taylored 7.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm taylored: affected >= 7.0.5, < 7.0.8; fixed in 7.0.8

## Suggested inspection (read-only)
- `npm ls taylored --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on taylored.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8g98-m4j9-qww5 (OSV record GHSA-8g98-m4j9-qww5 lists affected ranges: npm taylored >=7.0.5 <7.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-8g98-m4j9-qww5 (GitHub-reviewed advisory GHSA-8g98-m4j9-qww5 lists affected ranges: npm taylored >=7.0.5 <7.0.8)

Commands are suggestions: review each one before running it.

Loading voting…