Skip to content

← Actionable
Low, CVSS 2.1amended

@grackle-ai/server JSON.parse lacks try-catch logic in its gRPC Service AdapterConfig Handling

GHSA-8g29-8xwr-qmhr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/server 0.70.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact JSON.parse(env.adapterConfig) is called without error handling in three locations within the gRPC service. While the data originates from the server's own SQLite database and should always be valid JSON, database corruption, migration errors, or unexpected state could cause an unhandled exception that crashes the gRPC handler. Additionally, the parsed result is cast as Record<string, unknown and passed to adapter methods without property validation, creating a theoretical prototype pollution surface if the database is compromised. Affected code: - packages/server/src/grpc-service.ts:415 — reconnectOrProvision handler - packages/server/src/grpc-service.ts:482 — stopEnvironment handler - packages/server/src/grpc-service.ts:498 — destroyEnvironment handler Patches Fix: Wrap in try-catch and return a meaningful gRPC error: Workarounds Ensure database integrity. Back up the SQLite database regularly. Resources - CWE-754: Improper Check for Unusual or Exceptional Conditions - File:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8g29-8xwr-qmhr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8g29-8xwr-qmhr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8g29-8xwr-qmhr

Advisory: @grackle-ai/server JSON.parse lacks try-catch logic in its gRPC Service AdapterConfig Handling
IDs: GHSA-8g29-8xwr-qmhr
Record: https://patchnext.com/advisories/ghsa-8g29-8xwr-qmhr (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/server 0.70.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @grackle-ai/server: affected <= 0.70.5; fixed in 0.70.6

## Suggested inspection (read-only)
- `npm ls @grackle-ai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @grackle-ai/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8g29-8xwr-qmhr (OSV record GHSA-8g29-8xwr-qmhr lists affected ranges: npm @grackle-ai/server >=0 <0.70.6 (fixed))
- Verified: https://github.com/advisories/GHSA-8g29-8xwr-qmhr (GitHub-reviewed advisory GHSA-8g29-8xwr-qmhr lists affected ranges: npm @grackle-ai/server >=0 <=0.70.5)

Commands are suggestions: review each one before running it.

Loading voting…