Skip to content

← Actionable
Medium, CVSS 6.5amended

Nodemailer: A nested comment ends early in addressparser, releasing the rest of the comment as a recipient

CVE-2026-121424GHSA-8c8m-p3m8-cjg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 10.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nodemailer

    Affected
    >= 3.0.0, < 10.1.4
    Fixed in
    10.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Vulnerability summary RFC 5322 comments nest. addressparser ended a comment at the first `)`, including the one that closes a nested comment, and parsed the rest of the outer comment as header text. `Victim (x(y) ) ` names `v@victim.com` with `x(y) ` as a comment, and Nodemailer read it as the address `evil@evil.com`. This is the same shape as the escaped parenthesis fixed in 10.1.2, reached through nesting instead of a quoted-pair. Affected: 3.0.0 through 10.1.3.

Attacker capabilities The attacker controls the text of an address that an application passes to Nodemailer, or the From or To header of an inbound message parsed with mailparser. No access to the application, its configuration or its credentials is needed. The value is a syntactically valid RFC 5322 address that conformant parsers accept without defects.

Realistic exploitation scenario An application validates a submitted address with a conformant parser and allows only its own domain. The attacker submits…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-8c8m-p3m8-cjg8

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-8c8m-p3m8-cjg8

  3. Revision 2 · amended ·

    Amended from osv record GHSA-8c8m-p3m8-cjg8

  4. Revision 1 · created ·

    Published from ghsa record GHSA-8c8m-p3m8-cjg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-121424

Advisory: Nodemailer: A nested comment ends early in addressparser, releasing the rest of the comment as a recipient
IDs: CVE-2026-121424, GHSA-8c8m-p3m8-cjg8
Record: https://patchnext.com/advisories/ghsa-8c8m-p3m8-cjg8 (revision 4, source checked 4 Nov 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodemailer 10.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodemailer: affected >= 3.0.0, < 10.1.4; fixed in 10.1.4

## Suggested inspection (read-only)
- `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodemailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8c8m-p3m8-cjg8 (GitHub-reviewed advisory GHSA-8c8m-p3m8-cjg8 lists affected ranges: npm nodemailer >=3.0.0 <10.1.4)
- Verified: https://osv.dev/vulnerability/GHSA-8c8m-p3m8-cjg8 (OSV record GHSA-8c8m-p3m8-cjg8 lists affected ranges: npm nodemailer >=3.0.0 <10.1.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…