Reflected Cross-Site Scripting in redis-commander
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (redis-commander 0.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm redis-commander
- Affected
- < 0.5.0
- Fixed in
- 0.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8c8c-4vfj-rrpc lists affected ranges: npm redis-commander >=0.0.0 <0.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8c8c-4vfj-rrpc lists affected ranges: npm redis-commander >=0.0.0 <0.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Affected versions of redis-commander contain a cross-site scripting vulnerability in the highlighterId paramter of the clipboard.swf component on hosts serving Redis Commander. Mitigating factors: Flash must be installed / enabled for this to work. The below proof of concept was verified to work using Firefox 57.0 on Windows 10 by manually installing the Flash NPAPI Windows plugin Proof of concept Recommendation No direct patch for this vulnerability is currently available. At this time, the best mitigation is to use an alternative, functionally equivalent package, or to use extreme caution when using redis-commander, ensuring that redis-commmander is the only web page you have open, and avoiding clicking on any links.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8c8c-4vfj-rrpc
- Revision 1 · created ·
Published from osv record GHSA-8c8c-4vfj-rrpc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-8c8c-4vfj-rrpc Advisory: Reflected Cross-Site Scripting in redis-commander IDs: GHSA-8c8c-4vfj-rrpc Record: https://patchnext.com/advisories/ghsa-8c8c-4vfj-rrpc (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: redis-commander 0.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm redis-commander: affected < 0.5.0; fixed in 0.5.0 ## Suggested inspection (read-only) - `npm ls redis-commander --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on redis-commander. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8c8c-4vfj-rrpc (OSV record GHSA-8c8c-4vfj-rrpc lists affected ranges: npm redis-commander >=0.0.0 <0.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8c8c-4vfj-rrpc (GitHub-reviewed advisory GHSA-8c8c-4vfj-rrpc lists affected ranges: npm redis-commander >=0.0.0 <0.5.0) Commands are suggestions: review each one before running it.
Loading voting…