Skip to content

← Actionable
Unratedamended

Improper Verification of Cryptographic Signature in aws-encryption-sdk-cli

GHSA-89v2-g37m-g3ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws-encryption-sdk-cli 2.2.0, 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This advisory addresses several LOW severity issues with streaming signed messages and restricting processing of certain types of invalid messages. This ESDK supports a streaming mode where callers may stream the plaintext of signed messages before the ECDSA signature is validated. In addition to these signatures, the ESDK uses AES-GCM encryption and all plaintext is verified before being released to a caller. There is no impact on the integrity of the ciphertext or decrypted plaintext, however some callers may rely on the the ECDSA signature for non-repudiation. Without validating the ECDSA signature, an actor with trusted KMS permissions to decrypt a message may also be able to encrypt messages. This update introduces a new API for callers who wish to stream only unsigned messages. For customers who process ESDK messages from untrusted sources, this update also introduces a new configuration to limit the number of Encrypted Data Keys (EDKs) that the ESDK will attempt to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-89v2-g37m-g3ff

  2. Revision 1 · created ·

    Published from osv record GHSA-89v2-g37m-g3ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-89v2-g37m-g3ff

Advisory: Improper Verification of Cryptographic Signature in aws-encryption-sdk-cli
IDs: GHSA-89v2-g37m-g3ff
Record: https://patchnext.com/advisories/ghsa-89v2-g37m-g3ff (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aws-encryption-sdk-cli 2.2.0, 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aws-encryption-sdk-cli: affected < 1.9.0; >= 2.0.0, < 2.2.0; fixed in 2.2.0, 1.9.0

## Suggested inspection (read-only)
- `python -m pip show aws-encryption-sdk-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aws-encryption-sdk-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-89v2-g37m-g3ff (OSV record GHSA-89v2-g37m-g3ff lists affected ranges: PyPI aws-encryption-sdk-cli >=0 =2.0.0 <2.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-89v2-g37m-g3ff (GitHub-reviewed advisory GHSA-89v2-g37m-g3ff lists affected ranges: PyPI aws-encryption-sdk-cli >=0 =2.0.0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…