fgr Vulnerable to Insecure Default Variable Initialization
What to do
Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fgr
- Affected
- <= 0.3.2
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-879p-8gw4-mcpw lists affected ranges: PyPI fgr >=0 <=0.3.2
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-879p-8gw4-mcpw lists affected ranges: PyPI fgr >=0 <=0.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Any users whom would not desire a traceback to be included in their logs whenever an error is raised in their code will be affected. If users have inadvertently created a scenario in their code that could cause a traceback to include sensitive information and a malicious entity gained access to their log stream, this could create an issue. Patches None yet... users will need to upgrade to 0.4. Workarounds No particularly reasonable ones at present. References https://cwe.mitre.org/data/definitions/453.html https://www.invicti.com/web-vulnerability-scanner/vulnerabilities/stack-trace-disclosure-python/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-879p-8gw4-mcpw
- Revision 1 · created ·
Published from osv record GHSA-879p-8gw4-mcpw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-879p-8gw4-mcpw Advisory: fgr Vulnerable to Insecure Default Variable Initialization IDs: GHSA-879p-8gw4-mcpw Record: https://patchnext.com/advisories/ghsa-879p-8gw4-mcpw (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fgr: affected <= 0.3.2 ## Suggested inspection (read-only) - `python -m pip show fgr`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fgr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-879p-8gw4-mcpw (OSV record GHSA-879p-8gw4-mcpw lists affected ranges: PyPI fgr >=0 <=0.3.2) - Verified: https://github.com/advisories/GHSA-879p-8gw4-mcpw (GitHub-reviewed advisory GHSA-879p-8gw4-mcpw lists affected ranges: PyPI fgr >=0 <=0.3.2) Commands are suggestions: review each one before running it.
Loading voting…