Skip to content

← Actionable
Critical, CVSS 9.3

Auth0 Wordpress Plugin vulnerable to Deserialization of Untrusted Data

GHSA-862m-5253-832r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/wordpress 5.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Overview The Auth0 Wordpress plugin contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Am I Affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 WordPress plugin, versions between 5.0.0 BETA-0 to 5.0.1. 2. Auth0 WordPress plugin uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. Fix Upgrade the Auth0 WordPress plugin to the latest version (v5.3.0).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-862m-5253-832r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-862m-5253-832r

Advisory: Auth0 Wordpress Plugin vulnerable to Deserialization of Untrusted Data
IDs: GHSA-862m-5253-832r
Record: https://patchnext.com/advisories/ghsa-862m-5253-832r (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0/wordpress 5.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist auth0/wordpress: affected >= 5.0.0-BETA0, <= 5.0.1; fixed in 5.1.0

## Suggested inspection (read-only)
- Packagist auth0/wordpress: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0/wordpress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-862m-5253-832r (GitHub-reviewed advisory GHSA-862m-5253-832r lists affected ranges: Packagist auth0/wordpress >=5.0.0-BETA0 <=5.0.1)

Commands are suggestions: review each one before running it.

Loading voting…