Nodemailer: A ">" inside a quoted local part ends an angle-addr early in addressparser, delivering to a domain the header does not name
CVE-2026-121426GHSA-85x2-q946-cp5h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 10.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodemailer
- Affected
- >= 3.0.0, < 10.1.4
- Fixed in
- 10.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-85x2-q946-cp5h lists affected ranges: npm nodemailer >=3.0.0 <10.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-85x2-q946-cp5h lists affected ranges: npm nodemailer >=3.0.0 <10.1.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Vulnerability summary addressparser ends an angle-addr at the first `>` it sees, including one inside a quoted local part, a comment or a domain literal. The domain is then read off the text in front of that `>`. ` "@good.com>` is the mailbox `"a@evil.com>"@good.com` under RFC 5322, and Nodemailer read it as an address at `evil.com`. The unbracketed spelling of the same value was already read correctly. Affected: 3.0.0 through 10.1.3.
Attacker capabilities The attacker controls the text of a recipient or sender address that an application passes to Nodemailer, for example a To value entered in a contact or invite form, or the header of an inbound message parsed with mailparser. No access to the application, its configuration or its credentials is needed. The value is a syntactically valid RFC 5322 address that conformant parsers accept without defects.
Realistic exploitation scenario An application lets users send invitations or notifications only to addresses at an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-85x2-q946-cp5h
- Revision 3 · amended ·
Amended from ghsa record GHSA-85x2-q946-cp5h
- Revision 2 · amended ·
Amended from osv record GHSA-85x2-q946-cp5h
- Revision 1 · created ·
Published from ghsa record GHSA-85x2-q946-cp5h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-121426 Advisory: Nodemailer: A ">" inside a quoted local part ends an angle-addr early in addressparser, delivering to a domain the header does not name IDs: CVE-2026-121426, GHSA-85x2-q946-cp5h Record: https://patchnext.com/advisories/ghsa-85x2-q946-cp5h (revision 4, source checked 4 Nov 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodemailer 10.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodemailer: affected >= 3.0.0, < 10.1.4; fixed in 10.1.4 ## Suggested inspection (read-only) - `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodemailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-85x2-q946-cp5h (GitHub-reviewed advisory GHSA-85x2-q946-cp5h lists affected ranges: npm nodemailer >=3.0.0 <10.1.4) - Verified: https://osv.dev/vulnerability/GHSA-85x2-q946-cp5h (OSV record GHSA-85x2-q946-cp5h lists affected ranges: npm nodemailer >=3.0.0 <10.1.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…