XSS Vulnerability in Markdown Editor
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (inventree 0.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI inventree
- Affected
- < 0.7.3
- Fixed in
- 0.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-85q9-7467-r53q lists affected ranges: PyPI inventree >=0 <0.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-85q9-7467-r53q lists affected ranges: PyPI inventree >=0 <0.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact InvenTree uses EasyMDE for displaying markdown text in various places (e.g. for the various "notes" fields associated with various models). By default, EasyMDE does not sanitize input data, and it is possible for malicious code to be injected into the markdown editor, and executed in the users browser. Note: This malicious data must be first uploaded to the database by an authorized user, so the risk here is limited to trusted users Solution The solution here is two-fold: - Enable data sanitization for the EasyMDE renderer - #3205 - Enforce cleaning of all data uploaded to the database via the API - #3204 (This will be ready for the 0.8.0 release) Patches - The issue is addressed in the 0.8.0 release - This fix was back-ported to the 0.7.x branch, applied to the 0.7.3 release Workarounds There is no workaround for this issue without upgrading InvenTree to the specified version. References - https://huntr.dev/bounties/ab296cf5-7a3e-4f49-8f63-5b35fc707f03/ For more information…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-85q9-7467-r53q
- Revision 1 · created ·
Published from osv record GHSA-85q9-7467-r53q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-85q9-7467-r53q Advisory: XSS Vulnerability in Markdown Editor IDs: GHSA-85q9-7467-r53q Record: https://patchnext.com/advisories/ghsa-85q9-7467-r53q (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: inventree 0.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI inventree: affected < 0.7.3; fixed in 0.7.3 ## Suggested inspection (read-only) - `python -m pip show inventree`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on inventree. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-85q9-7467-r53q (OSV record GHSA-85q9-7467-r53q lists affected ranges: PyPI inventree >=0 <0.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-85q9-7467-r53q (GitHub-reviewed advisory GHSA-85q9-7467-r53q lists affected ranges: PyPI inventree >=0 <0.7.3) Commands are suggestions: review each one before running it.
Loading voting…