@nfid/embed has compromised private key due to @dfinity/auth-client producing insecure session keys
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nfid/embed 0.10.1-alpha.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @nfid/embed
- Affected
- >= 0.10.0, < 0.10.1-alpha.6
- Fixed in
- 0.10.1-alpha.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-84c3-j8r2-mcm8 lists affected ranges: npm @nfid/embed >=0.10.0 <0.10.1-alpha.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-84c3-j8r2-mcm8 lists affected ranges: npm @nfid/embed >=0.10.0 <0.10.1-alpha.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Problem User sessions in the @nfid/embed SDK with Ed25519 keys are vulnerable due to a compromised private key 535yc-uxytb-gfk7h-tny7p-vjkoe-i4krp-3qmcl-uqfgr-cpgej-yqtjq-rqe. This exposes users to potential loss of funds on ledgers and unauthorized access to canisters they control. Solution Using version 1.0.1 of @dfinity/auth-client and @dfinity/identity packages, or @nfid/embed 0.10.1-alpha.6 includes patched versions of the issue. User sessions will be automatically fixed when they re-authenticate. Why this happened The DFINITY auth client library provides a function, Ed25519KeyIdentity.generate, for generating an Ed25519 key pair. This function includes an optional parameter to supply a 32-byte seed value, which will be utilized as the secret key. In cases where no seed value is provided, the library is expected to generate the secret key using secure randomness. However, a recent update of DFINITY libraries has compromised this assurance by employing an insecure seed for key…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-84c3-j8r2-mcm8
- Revision 1 · created ·
Published from osv record GHSA-84c3-j8r2-mcm8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-84c3-j8r2-mcm8 Advisory: @nfid/embed has compromised private key due to @dfinity/auth-client producing insecure session keys IDs: GHSA-84c3-j8r2-mcm8 Record: https://patchnext.com/advisories/ghsa-84c3-j8r2-mcm8 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nfid/embed 0.10.1-alpha.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nfid/embed: affected >= 0.10.0, < 0.10.1-alpha.6; fixed in 0.10.1-alpha.6 ## Suggested inspection (read-only) - `npm ls @nfid/embed --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nfid/embed. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-84c3-j8r2-mcm8 (OSV record GHSA-84c3-j8r2-mcm8 lists affected ranges: npm @nfid/embed >=0.10.0 <0.10.1-alpha.6 (fixed)) - Verified: https://github.com/advisories/GHSA-84c3-j8r2-mcm8 (GitHub-reviewed advisory GHSA-84c3-j8r2-mcm8 lists affected ranges: npm @nfid/embed >=0.10.0 <0.10.1-alpha.6) Commands are suggestions: review each one before running it.
Loading voting…