Skip to content

← Actionable
Medium, CVSS 6.9

tornado: multipart split() creates huge temp list before max_parts check -> memory amplification DoS (httputil.py:34)

GHSA-8423-8fgw-73vq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    <= 6.5.7
    Fixed in
    6.5.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description Summary parsemultipartformdata (httputil.py:34) calls data.split(b"--"+boundary+b"\r\n") before the maxparts check (:35). A 600KB body with 100k parts creates a 100k-element transient list first, then rejects transient memory amplification (each split element is a copy). Pre-auth HTTP DoS. Root cause PoC gist: https://gist.github.com/afldl/649861f25d39b53b7edbe0298e171617 poc.py + output.txt (100k parts from 600KB transient list). Fix Count separators without materializing the list (e.g. data.count(b"--"+boundary) first). Credit Reported by afldl, 2026-07.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8423-8fgw-73vq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8423-8fgw-73vq

Advisory: tornado: multipart split() creates huge temp list before max_parts check -> memory amplification DoS (httputil.py:34)
IDs: GHSA-8423-8fgw-73vq
Record: https://patchnext.com/advisories/ghsa-8423-8fgw-73vq (revision 1, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected <= 6.5.7; fixed in 6.5.8

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8423-8fgw-73vq (GitHub-reviewed advisory GHSA-8423-8fgw-73vq lists affected ranges: PyPI tornado >=0 <=6.5.7)

Commands are suggestions: review each one before running it.

Loading voting…