Skip to content

← Actionable
Low, CVSS 3.7

OpenSearch has a bypass of REST Layer Authorization Using Malformed Paths

GHSA-83x9-vc3c-hghc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.plugin:opensearch-security 2.19.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description A flaw was identified in the OpenSearch REST layer that could allow authorization checks to be bypassed when processing certain malformed HTTP requests. This could permit unauthorized access to restricted API endpoints in environments that rely on REST-layer authorization. Transport-level authorization is not affected by this issue. Impact The default OpenSearch distribution is not affected by this issue. REST actions in the default distribution have corresponding transport actions that independently enforce authorization. Custom plugins that register REST actions without a corresponding transport action may be affected, potentially allowing unauthorized read access to those endpoints. Patches This issue is fixed in OpenSearch 2.19.0. Users should upgrade to 2.19.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-83x9-vc3c-hghc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-83x9-vc3c-hghc

Advisory: OpenSearch has a bypass of REST Layer Authorization Using Malformed Paths
IDs: GHSA-83x9-vc3c-hghc
Record: https://patchnext.com/advisories/ghsa-83x9-vc3c-hghc (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opensearch.plugin:opensearch-security 2.19.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opensearch.plugin:opensearch-security: affected >= 2.11.0.0, < 2.19.0.0; fixed in 2.19.0.0

## Suggested inspection (read-only)
- Maven org.opensearch.plugin:opensearch-security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opensearch.plugin:opensearch-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-83x9-vc3c-hghc (GitHub-reviewed advisory GHSA-83x9-vc3c-hghc lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=2.11.0.0 <2.19.0.0)

Commands are suggestions: review each one before running it.

Loading voting…