Namada-apps can Crash with Excessive Computation in Mempool Validation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (namada-apps 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io namada-apps
- Affected
- >= 1.0.0, <= 1.0.0
- Fixed in
- 1.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-82vg-5v4f-f9wq lists affected ranges: crates.io namada-apps >=1.0.0 <=1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A malicious transaction may cause a crash in mempool validation. A transaction with authorization section containing 256 public keys or more with valid matching signatures triggers an integer overflow in signature verification that causes a the node to panic. Patches This issue has been patched in apps version 1.1.0. The mempool validation has been fixed to avoid overflow. Workarounds There are no workarounds and users are advised to upgrade.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-82vg-5v4f-f9wq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-82vg-5v4f-f9wq Advisory: Namada-apps can Crash with Excessive Computation in Mempool Validation IDs: GHSA-82vg-5v4f-f9wq Record: https://patchnext.com/advisories/ghsa-82vg-5v4f-f9wq (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: namada-apps 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io namada-apps: affected >= 1.0.0, <= 1.0.0; fixed in 1.1.0 ## Suggested inspection (read-only) - crates.io namada-apps: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on namada-apps. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-82vg-5v4f-f9wq (GitHub-reviewed advisory GHSA-82vg-5v4f-f9wq lists affected ranges: crates.io namada-apps >=1.0.0 <=1.0.0) Commands are suggestions: review each one before running it.
Loading voting…