Skip to content

← Actionable
Unrated

eZ Publish Legacy Patch EZSA-2018-001 for Several vulnerabilities

GHSA-82rv-45pc-v28w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2017.12.2.1, 5.4.11.3, 5.3.12.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist ezsystems/ezpublish-legacy

    Affected
    >= 2011.0.0, < 2017.12.2.1>= 5.4.0, < 5.4.11.3>= 5.3.0, < 5.3.12.3
    Fixed in
    5.3.12.3, 5.4.11.3, 2017.12.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This security advisory fixes 4 separate vulnerabilities in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy by itself or via the LegacyBridge. First, it increases the randomness, and thus the security, of the pseudo-random bytes used to generate a hash for the "forgot password" feature. This protects accounts against being taken over through attacks trying to predict the hash. If the increased randomness is not available in your PHP installation, it will now log a warning. Second, it improves security of the information collector feature, by ensuring no collection emails will be sent from invalid manipulated forms. Third, it stops the possible leaking of the names of content objects that should not be readable for certain users, on installations where these users can create or edit XML text. Fourth, it protects against cross-site scripting (XSS) in the Matrix data type, on installations where users are allowed to edit content classes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-82rv-45pc-v28w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-82rv-45pc-v28w

Advisory: eZ Publish Legacy Patch EZSA-2018-001 for Several vulnerabilities
IDs: GHSA-82rv-45pc-v28w
Record: https://patchnext.com/advisories/ghsa-82rv-45pc-v28w (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2017.12.2.1, 5.4.11.3, 5.3.12.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ezsystems/ezpublish-legacy: affected >= 2011.0.0, < 2017.12.2.1; >= 5.4.0, < 5.4.11.3; >= 5.3.0, < 5.3.12.3; fixed in 5.3.12.3, 5.4.11.3, 2017.12.2.1

## Suggested inspection (read-only)
- Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ezsystems/ezpublish-legacy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-82rv-45pc-v28w (GitHub-reviewed advisory GHSA-82rv-45pc-v28w lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2011.0.0 =5.4.0 =5.3.0 <5.3.12.3)

Commands are suggestions: review each one before running it.

Loading voting…