Prototype pollution in emit function
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (derby 4.0.0-beta.11, 3.0.2, 2.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm derby
- Affected
- <= 2.3.1>= 3.0.0, <= 3.0.1>= 4.0.0-beta1, <= 4.0.0-beta.10
- Fixed in
- 4.0.0-beta.11, 3.0.2, 2.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-82jv-9wjw-pqh6 lists affected ranges: npm derby >=0 =3.0.0 =4.0.0-beta1 <4.0.0-beta.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-82jv-9wjw-pqh6 lists affected ranges: npm derby >=0 =3.0.0 =4.0.0-beta1 <=4.0.0-beta.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A prototype pollution in derby can crash the application, if the application author has atypical HTML templates that feed user input into an object key. Attribute keys are almost always developer-controlled, not end-user-controlled, so this shouldn't be an issue in practice for most applications. Details The emit() function in src/templates/templates.ts is called without sanitizing the variable this.lastSegment . The variable this.lastSegment can be set to proto, and this will pollute the prototype of Javascipt Object (node['proto'] = target). PoC To reproduce this vulnerability, you can adjust the test case ignores DOM mutations in components\' create() in test/dom/ComponentHarness.mocha.js. When as attribute is controlled by attackers, the variable in this.lastSegment will exactly take value proto and prototype pollution happens. Patch Add a check on this.lastSegment can prevent this attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-82jv-9wjw-pqh6
- Revision 1 · created ·
Published from osv record GHSA-82jv-9wjw-pqh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-82jv-9wjw-pqh6 Advisory: Prototype pollution in emit function IDs: GHSA-82jv-9wjw-pqh6 Record: https://patchnext.com/advisories/ghsa-82jv-9wjw-pqh6 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: derby 4.0.0-beta.11, 3.0.2, 2.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm derby: affected <= 2.3.1; >= 3.0.0, <= 3.0.1; >= 4.0.0-beta1, <= 4.0.0-beta.10; fixed in 4.0.0-beta.11, 3.0.2, 2.3.2 ## Suggested inspection (read-only) - `npm ls derby --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on derby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-82jv-9wjw-pqh6 (OSV record GHSA-82jv-9wjw-pqh6 lists affected ranges: npm derby >=0 =3.0.0 =4.0.0-beta1 <4.0.0-beta.11 (fixed)) - Verified: https://github.com/advisories/GHSA-82jv-9wjw-pqh6 (GitHub-reviewed advisory GHSA-82jv-9wjw-pqh6 lists affected ranges: npm derby >=0 =3.0.0 =4.0.0-beta1 <=4.0.0-beta.10) Commands are suggestions: review each one before running it.
Loading voting…