Skip to content

← Actionable
High, CVSS 7.5

rustls-webpki: Denial of service via panic on malformed CRL BIT STRING

GHSA-82j2-j2ch-gfr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rustls-webpki 0.104.0-alpha.7, 0.103.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io rustls-webpki

    Affected
    < 0.103.13>= 0.104.0-alpha.1, < 0.104.0-alpha.7
    Fixed in
    0.103.13, 0.104.0-alpha.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary bitstringflags() in src/der.rs panics with an index-out-of-bounds when given a BIT STRING whose content is exactly [0x00] (one byte: zero padding bits, zero data bytes). This is reachable through the public API BorrowedCertRevocationList::fromder() via the issuingDistributionPoint CRL extension. Precondition: CRL checking is opt-in in rustls-webpki. This vulnerability affects only applications that explicitly pass RevocationOptions to verifyforusage() and load CRL bytes from a source the attacker can influence. The default rustls configuration (no RevocationOptions) is not affected. AI disclosure: This report was prepared with AI assistance (Claude). The vulnerability was discovered by differential fuzzing against a formally-verified Rust oracle. All technical claims have been independently verified against the live source code before submission. Details bitstringflags() in src/der.rs reads the content of named-bit BIT STRINGs (KeyUsage, ReasonFlags, etc.). Its input guard:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-82j2-j2ch-gfr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-82j2-j2ch-gfr8

Advisory: rustls-webpki: Denial of service via panic on malformed CRL BIT STRING
IDs: GHSA-82j2-j2ch-gfr8
Record: https://patchnext.com/advisories/ghsa-82j2-j2ch-gfr8 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rustls-webpki 0.104.0-alpha.7, 0.103.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io rustls-webpki: affected < 0.103.13; >= 0.104.0-alpha.1, < 0.104.0-alpha.7; fixed in 0.103.13, 0.104.0-alpha.7

## Suggested inspection (read-only)
- crates.io rustls-webpki: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rustls-webpki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-82j2-j2ch-gfr8 (GitHub-reviewed advisory GHSA-82j2-j2ch-gfr8 lists affected ranges: crates.io rustls-webpki >=0 =0.104.0-alpha.1 <0.104.0-alpha.7)

Commands are suggestions: review each one before running it.

Loading voting…