Skip to content

← Actionable
Critical, CVSS 9.9

GeoTools has XML External Entity (XXE) Processing Vulnerability in XSD schema handling

GHSA-826p-4gcg-35vw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geotools:gt-xsd-core 33.1, 32.3, 31.7, 28.6.1; org.geotools:gt-wfs-ng 33.1, 32.3, 31.7, 28.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.geotools:gt-xsd-core

    Affected
    >= 33.0, <= 33.0>= 32.0, < 32.3>= 29.0, <= 31.6< 28.6.1
    Fixed in
    32.3, 33.1, 31.7, 28.6.1
  • Maven org.geotools:gt-wfs-ng

    Affected
    >= 33.0, < 33.1>= 32.0, < 32.3>= 29.0, <= 31.6< 28.6.1
    Fixed in
    32.3, 33.1, 31.7, 28.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary GeoTools Schema class use of Eclipse XSD library to represent schema data structure is vulnerable to XML External Entity (XXE) exploit. Impact This impacts whoever exposes XML processing with gt-xsd-core involved in parsing, when the documents carry a reference to an external XML schema. The gt-xsd-core Schemas class is not using the EntityResolver provided by the ParserHandler (if any was configured). This also impacts users of gt-wfs-ng DataStore where the ENTITYRESOLVER connection parameter was not being used as intended. Resolution GeoTools API change allows EntityResolver to be supplied to the following methods: With this API change the gt-wfs-ng WFS DataStore ENTITYRESOLVER parameter is now used. Reference GHSA-jj54-8f66-c5pc: Describes the impact of the gt-xsd-core vulnerability on the GeoServer WFS protocol, resulting in both Service Side Request Forgery (SSRF) and Out-of-Band (OOB) data exfiltration of local files. GHSA-2p76-gc46-5fvc: Describes the impact of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-826p-4gcg-35vw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-826p-4gcg-35vw

Advisory: GeoTools has XML External Entity (XXE) Processing Vulnerability in XSD schema handling
IDs: GHSA-826p-4gcg-35vw
Record: https://patchnext.com/advisories/ghsa-826p-4gcg-35vw (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geotools:gt-xsd-core 33.1, 32.3, 31.7, 28.6.1; org.geotools:gt-wfs-ng 33.1, 32.3, 31.7, 28.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geotools:gt-xsd-core: affected >= 33.0, <= 33.0; >= 32.0, < 32.3; >= 29.0, <= 31.6; < 28.6.1; fixed in 32.3, 33.1, 31.7, 28.6.1
- Maven org.geotools:gt-wfs-ng: affected >= 33.0, < 33.1; >= 32.0, < 32.3; >= 29.0, <= 31.6; < 28.6.1; fixed in 32.3, 33.1, 31.7, 28.6.1

## Suggested inspection (read-only)
- Maven org.geotools:gt-xsd-core: check the installed version with your package manager.
- Maven org.geotools:gt-wfs-ng: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geotools:gt-xsd-core, org.geotools:gt-wfs-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-826p-4gcg-35vw (GitHub-reviewed advisory GHSA-826p-4gcg-35vw lists affected ranges: Maven org.geotools:gt-xsd-core >=33.0 =32.0 =29.0 =0 =33.0 =32.0 =29.0 =0 <28.6.1)

Commands are suggestions: review each one before running it.

Loading voting…