Skip to content

← Actionable
Medium, CVSS 6.8amended

FastMCP: Post-transform component authorization is skipped on direct calls

GHSA-7xgj-8392-5q4r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastmcp 4.1.2, 3.4.10; fastmcp-slim 4.1.2, 3.4.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fastmcp

    Affected
    >= 3.0.0, < 3.4.10>= 4.0.0, < 4.1.2
    Fixed in
    4.1.2, 3.4.10
  • PyPI fastmcp-slim

    Affected
    >= 3.0.0, < 3.4.10>= 4.0.0, < 4.1.2
    Fixed in
    4.1.2, 3.4.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Maintainer assessment and remediation This report is accepted as a FastMCP authorization vulnerability. In supported configurations, a server transform can change the metadata used by a component's authorization policy. Direct lookups previously checked the original component but returned the transformed component without rechecking its policy. A client that knows the component identifier can invoke a tool or retrieve a resource or prompt that the configured policy denies. The fixes authorize the final transformed tools, resources, templates, and prompts. A denied concrete resource also shadows a matching resource template at its URI, preventing proxy templates from retrieving the same protected resource upstream. Authorized callers, authorized component versions, and templates for genuinely absent concrete resources remain supported. Affected stable release lines: FastMCP 3.0.0–3.4.9 and 4.0.0–4.1.1. The missing final authorization check is present in v3.0.0 history and was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7xgj-8392-5q4r

  2. Revision 2 · amended ·

    Amended from osv record GHSA-7xgj-8392-5q4r

  3. Revision 1 · created ·

    Published from ghsa record GHSA-7xgj-8392-5q4r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7xgj-8392-5q4r

Advisory: FastMCP: Post-transform component authorization is skipped on direct calls
IDs: GHSA-7xgj-8392-5q4r
Record: https://patchnext.com/advisories/ghsa-7xgj-8392-5q4r (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastmcp 4.1.2, 3.4.10; fastmcp-slim 4.1.2, 3.4.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastmcp: affected >= 3.0.0, < 3.4.10; >= 4.0.0, < 4.1.2; fixed in 4.1.2, 3.4.10
- PyPI fastmcp-slim: affected >= 3.0.0, < 3.4.10; >= 4.0.0, < 4.1.2; fixed in 4.1.2, 3.4.10

## Suggested inspection (read-only)
- `python -m pip show fastmcp`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show fastmcp-slim`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastmcp, fastmcp-slim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7xgj-8392-5q4r (GitHub-reviewed advisory GHSA-7xgj-8392-5q4r lists affected ranges: PyPI fastmcp >=3.0.0 =4.0.0 =3.0.0 =4.0.0 <4.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-7xgj-8392-5q4r (OSV record GHSA-7xgj-8392-5q4r lists affected ranges: PyPI fastmcp >=3.0.0 =4.0.0 =3.0.0 =4.0.0 <4.1.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…