ciguard: Web UI is missing HTTP defence-in-depth headers
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ciguard 0.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ciguard
- Affected
- >= 0.1.0, <= 0.8.1
- Fixed in
- 0.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7ww3-xvf5-cxwm lists affected ranges: PyPI ciguard >=0.1.0 <0.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7ww3-xvf5-cxwm lists affected ranges: PyPI ciguard >=0.1.0 <=0.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary ciguard's FastAPI Web UI (src/ciguard/web/app.py) does not set HTTP defence-in-depth headers. OWASP ZAP baseline scan flagged 11 alerts: missing Content-Security-Policy (Medium), X-Frame-Options (Medium), Sub-Resource-Integrity on /api/docs (Medium), COOP / COEP / CORP (Low), Permissions-Policy (Low), X-Content-Type-Options (Low). Threat scenario For local-only deployment (current intent): minimal — there's no untrusted browser context, no third-party hosting, no auth surface to protect. For public hosting (PRD Slice 9 GitHub App or hosted dashboard, future): each missing header reduces a defence layer: - Missing CSP → injected XSS would have no second-line defence (first-line Jinja autoescape remains intact) - Missing X-Frame-Options → clickjacking against any UI button would be possible - Missing SRI on jsdelivr-hosted Swagger UI → if jsdelivr were compromised, attacker JS would run in the docs page context Patch - New SecurityHeadersMiddleware at…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7ww3-xvf5-cxwm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7ww3-xvf5-cxwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7ww3-xvf5-cxwm Advisory: ciguard: Web UI is missing HTTP defence-in-depth headers IDs: GHSA-7ww3-xvf5-cxwm Record: https://patchnext.com/advisories/ghsa-7ww3-xvf5-cxwm (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ciguard 0.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ciguard: affected >= 0.1.0, <= 0.8.1; fixed in 0.8.2 ## Suggested inspection (read-only) - `python -m pip show ciguard`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ciguard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7ww3-xvf5-cxwm (OSV record GHSA-7ww3-xvf5-cxwm lists affected ranges: PyPI ciguard >=0.1.0 <0.8.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7ww3-xvf5-cxwm (GitHub-reviewed advisory GHSA-7ww3-xvf5-cxwm lists affected ranges: PyPI ciguard >=0.1.0 <=0.8.1) Commands are suggestions: review each one before running it.
Loading voting…