Cookie leakage between different users in fastapi-proxy-lib
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi-proxy-lib 0.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fastapi-proxy-lib
- Affected
- < 0.1.0
- Fixed in
- 0.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7vwr-g6pm-9hc8 lists affected ranges: PyPI fastapi-proxy-lib >=0 <0.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7vwr-g6pm-9hc8 lists affected ranges: PyPI fastapi-proxy-lib >=0 <0.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact In the implementation of version 0.0.1, requests from different user clients are processed using a shared httpx.AsyncClient. However, one oversight is that the httpx.AsyncClient will persistently store cookies based on the set-cookie response header sent by the target server and share these cookies across different user requests. This results in a cookie leakage issue among all user clients sharing the same httpx.AsyncClient. Patches It's fixed in 0.1.0 Workarounds If you insist 0.0.1: - Do not use ForwardHttpProxy at all. - Do not use ReverseHttpProxy or ReverseWebSocketProxy for any servers that may potentially send a set-cookie response. However, it's best to upgrade to the latest version. References fixed in #10
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7vwr-g6pm-9hc8
- Revision 1 · created ·
Published from osv record GHSA-7vwr-g6pm-9hc8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7vwr-g6pm-9hc8 Advisory: Cookie leakage between different users in fastapi-proxy-lib IDs: GHSA-7vwr-g6pm-9hc8 Record: https://patchnext.com/advisories/ghsa-7vwr-g6pm-9hc8 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastapi-proxy-lib 0.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fastapi-proxy-lib: affected < 0.1.0; fixed in 0.1.0 ## Suggested inspection (read-only) - `python -m pip show fastapi-proxy-lib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastapi-proxy-lib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7vwr-g6pm-9hc8 (OSV record GHSA-7vwr-g6pm-9hc8 lists affected ranges: PyPI fastapi-proxy-lib >=0 <0.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7vwr-g6pm-9hc8 (GitHub-reviewed advisory GHSA-7vwr-g6pm-9hc8 lists affected ranges: PyPI fastapi-proxy-lib >=0 <0.1.0) Commands are suggestions: review each one before running it.
Loading voting…