/user/sessions endpoint allows detecting valid accounts
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezplatform-rest 1.3.1.1, 1.2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezplatform-rest
- Affected
- >= 1.2.0, <= 1.2.2.0>= 1.3.0, <= 1.3.1.0
- Fixed in
- 1.3.1.1, 1.2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7vwg-39h8-8qp8 lists affected ranges: Packagist ezsystems/ezplatform-rest >=1.2.0 =1.3.0 <=1.3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This Security Advisory is about a vulnerability in eZ Platform v1.13, v2.5, and v3.2, and in Ibexa DXP and Ibexa Open Source v3.3. The /user/sessions endpoint can let an attacker detect if a given username or email refers to a valid account. This can be detected through differences in the response data or response time of certain requests. The fix ensures neither attack is possible. The fix is distributed via Composer. If you come across a security issue in our products, here is how you can report it to us: https://doc.ibexa.co/en/latest/guide/reportingissues/#toc
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7vwg-39h8-8qp8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7vwg-39h8-8qp8 Advisory: /user/sessions endpoint allows detecting valid accounts IDs: GHSA-7vwg-39h8-8qp8 Record: https://patchnext.com/advisories/ghsa-7vwg-39h8-8qp8 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezplatform-rest 1.3.1.1, 1.2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezplatform-rest: affected >= 1.2.0, <= 1.2.2.0; >= 1.3.0, <= 1.3.1.0; fixed in 1.3.1.1, 1.2.2.1 ## Suggested inspection (read-only) - Packagist ezsystems/ezplatform-rest: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezplatform-rest. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7vwg-39h8-8qp8 (GitHub-reviewed advisory GHSA-7vwg-39h8-8qp8 lists affected ranges: Packagist ezsystems/ezplatform-rest >=1.2.0 =1.3.0 <=1.3.1.0) Commands are suggestions: review each one before running it.
Loading voting…