Skip to content

← Actionable
Critical, CVSS 9.8

Propel2 SQL injection possible with limit() on MySQL

GHSA-7vw7-qx38-37vr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (propel/propel 2.0.0-alpha8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist propel/propel

    Affected
    >= 2.0.0-alpha1, <= 2.0.0-alpha7
    Fixed in
    2.0.0-alpha8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The limit() query method is susceptible to catastrophic SQL injection with MySQL. For example, given a model User for a table users: This will drop the users table! The cause appears to be a lack of integer casting of the limit input in either Propel\Runtime\ActiveQuery\Criteria::setLimit() or in Propel\Runtime\Adapter\Pdo\MysqlAdapter::applyLimit(). The code comments there seem to imply that casting was avoided due to overflow issues with 32-bit integers. This is surprising behavior since one of the primary purposes of an ORM is to prevent basic SQL injection. This affects all versions of Propel: 1.x, 2.x, and 3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7vw7-qx38-37vr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7vw7-qx38-37vr

Advisory: Propel2 SQL injection possible with limit() on MySQL
IDs: GHSA-7vw7-qx38-37vr
Record: https://patchnext.com/advisories/ghsa-7vw7-qx38-37vr (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: propel/propel 2.0.0-alpha8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist propel/propel: affected >= 2.0.0-alpha1, <= 2.0.0-alpha7; fixed in 2.0.0-alpha8

## Suggested inspection (read-only)
- Packagist propel/propel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on propel/propel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7vw7-qx38-37vr (GitHub-reviewed advisory GHSA-7vw7-qx38-37vr lists affected ranges: Packagist propel/propel >=2.0.0-alpha1 <=2.0.0-alpha7)

Commands are suggestions: review each one before running it.

Loading voting…