Skip to content

← Actionable
Unrated

Drupal Core Insufficient Contextual Links validation leads to Remote Code Execution

GHSA-7v68-3pr5-h3cr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.6.2, 8.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.0.0, < 8.5.8>= 8.6.0, < 8.6.2
    Fixed in
    8.5.8, 8.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The Contextual Links module doesn't sufficiently validate the requested contextual links. This vulnerability is mitigated by the fact that an attacker must have a role with the permission "access contextual links".

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7v68-3pr5-h3cr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7v68-3pr5-h3cr

Advisory: Drupal Core Insufficient Contextual Links validation leads to Remote Code Execution
IDs: GHSA-7v68-3pr5-h3cr
Record: https://patchnext.com/advisories/ghsa-7v68-3pr5-h3cr (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.6.2, 8.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.0.0, < 8.5.8; >= 8.6.0, < 8.6.2; fixed in 8.5.8, 8.6.2

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7v68-3pr5-h3cr (GitHub-reviewed advisory GHSA-7v68-3pr5-h3cr lists affected ranges: Packagist drupal/core >=8.0.0 =8.6.0 <8.6.2)

Commands are suggestions: review each one before running it.

Loading voting…