Skip to content

← Actionable
Medium, CVSS 6.0

Insufficient Session Expiration in Pterodactyl API

GHSA-7v3x-h7r2-34jv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability exists in Pterodactyl Panel <= 1.6.6 that could allow a malicious attacker that compromises an API key to generate an authenticated user session that is not revoked when the API key is deleted, thus allowing the malicious user to remain logged in as the user the key belonged to. It is important to note that a malicious user must first compromise an existing API key for a user to exploit this issue. It cannot be exploited by chance, and requires a coordinated attack against an individual account using a known API key. Patches This issue has been addressed in the v1.7.0 release of Pterodactyl Panel. Workarounds Those not wishing to upgrade may apply the change below: For more information If you have any questions or comments about this advisory please reach out to Tactical Fish#8008 on Discord or email dane@pterodactyl.io.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7v3x-h7r2-34jv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7v3x-h7r2-34jv

Advisory: Insufficient Session Expiration in Pterodactyl API
IDs: GHSA-7v3x-h7r2-34jv
Record: https://patchnext.com/advisories/ghsa-7v3x-h7r2-34jv (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pterodactyl/panel: affected < 1.7.0; fixed in 1.7.0

## Suggested inspection (read-only)
- Packagist pterodactyl/panel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pterodactyl/panel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7v3x-h7r2-34jv (GitHub-reviewed advisory GHSA-7v3x-h7r2-34jv lists affected ranges: Packagist pterodactyl/panel >=0 <1.7.0)

Commands are suggestions: review each one before running it.

Loading voting…