Ghost vulnerable to remote code execution in locale setting change
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 5.2.3, 4.48.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- < 4.48.2>= 5.0.0, < 5.2.3
- Fixed in
- 5.2.3, 4.48.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7v28-g2pq-ggg8 lists affected ranges: npm ghost >=0 =5.0.0 <5.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7v28-g2pq-ggg8 lists affected ranges: npm ghost >=0 =5.0.0 <5.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor. Patches Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible. Workarounds Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete solution. As a workaround, if for any reason you cannot update your Ghost instance, you can block the POST /ghost/api/admin/settings/ endpoint, which will also disable updating settings for your site. For more information If you have any questions or comments about this advisory: Email us at security@ghost.org Credits devx00 - https://twitter.com/devx00
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7v28-g2pq-ggg8
- Revision 1 · created ·
Published from osv record GHSA-7v28-g2pq-ggg8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7v28-g2pq-ggg8 Advisory: Ghost vulnerable to remote code execution in locale setting change IDs: GHSA-7v28-g2pq-ggg8 Record: https://patchnext.com/advisories/ghsa-7v28-g2pq-ggg8 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 5.2.3, 4.48.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected < 4.48.2; >= 5.0.0, < 5.2.3; fixed in 5.2.3, 4.48.2 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7v28-g2pq-ggg8 (OSV record GHSA-7v28-g2pq-ggg8 lists affected ranges: npm ghost >=0 =5.0.0 <5.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-7v28-g2pq-ggg8 (GitHub-reviewed advisory GHSA-7v28-g2pq-ggg8 lists affected ranges: npm ghost >=0 =5.0.0 <5.2.3) Commands are suggestions: review each one before running it.
Loading voting…