Nokogiri updates packaged dependency on libxml2 from 2.9.10 to 2.9.12
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems nokogiri
- Affected
- < 1.11.4
- Fixed in
- 1.11.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7rrm-v45f-jp64 lists affected ranges: RubyGems nokogiri >=0 <1.11.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Nokogiri v1.11.4 updates the vendored libxml2 from v2.9.10 to v2.9.12 which addresses: - CVE-2019-20388 (Medium severity) - CVE-2020-24977 (Medium severity) - CVE-2021-3517 (Medium severity) - CVE-2021-3518 (Medium severity) - CVE-2021-3537 (Low severity) - CVE-2021-3541 (Low severity) Note that two additional CVEs were addressed upstream but are not relevant to this release. CVE-2021-3516 via xmllint is not present in Nokogiri, and CVE-2020-7595 has been patched in Nokogiri since v1.10.8 (see #1992). Please note that this advisory only applies to the CRuby implementation of Nokogiri < 1.11.4, and only if the packaged version of libxml2 is being used. If you've overridden defaults at installation time to use system libraries instead of packaged libraries, you should instead pay attention to your distro's libxml2 release announcements. Mitigation Upgrade to Nokogiri = 1.11.4. Impact I've done a brief analysis of the published CVEs that are addressed in this upstream release.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7rrm-v45f-jp64
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7rrm-v45f-jp64 Advisory: Nokogiri updates packaged dependency on libxml2 from 2.9.10 to 2.9.12 IDs: GHSA-7rrm-v45f-jp64 Record: https://patchnext.com/advisories/ghsa-7rrm-v45f-jp64 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems nokogiri: affected < 1.11.4; fixed in 1.11.4 ## Suggested inspection (read-only) - RubyGems nokogiri: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nokogiri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7rrm-v45f-jp64 (GitHub-reviewed advisory GHSA-7rrm-v45f-jp64 lists affected ranges: RubyGems nokogiri >=0 <1.11.4) Commands are suggestions: review each one before running it.
Loading voting…