Skip to content

← Actionable
Low, CVSS 2.3amended

@grackle-ai/server: Unescaped Error String in renderPairingPage() HTML Template

GHSA-7q9x-8g6p-3x75

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/server 0.70.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact The renderPairingPage() function embeds the error parameter directly into HTML without escaping: All current call sites pass hardcoded strings, so this is not exploitable today. However, the function is architecturally fragile — if a future code change passes user-controlled or dynamic content into the error parameter, it would create an XSS vulnerability. The renderAuthorizePage() function in the same file correctly uses escapeHtml() for dynamic content, making this an inconsistency. Affected code: - packages/server/src/index.ts:64-89 — renderPairingPage() with unescaped error interpolation - Compare: packages/server/src/index.ts:130 — renderAuthorizePage() correctly uses escapeHtml() Patches v0.70.1 Fix: Apply escapeHtml() to the error parameter: Workarounds No workaround needed — all current callers pass hardcoded strings. Resources - CWE-79: Improper Neutralization of Input During Web Page Generation - File: packages/server/src/index.ts

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7q9x-8g6p-3x75

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7q9x-8g6p-3x75

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7q9x-8g6p-3x75

Advisory: @grackle-ai/server: Unescaped Error String in renderPairingPage() HTML Template
IDs: GHSA-7q9x-8g6p-3x75
Record: https://patchnext.com/advisories/ghsa-7q9x-8g6p-3x75 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/server 0.70.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @grackle-ai/server: affected <= 0.70.0; fixed in 0.70.1

## Suggested inspection (read-only)
- `npm ls @grackle-ai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @grackle-ai/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7q9x-8g6p-3x75 (OSV record GHSA-7q9x-8g6p-3x75 lists affected ranges: npm @grackle-ai/server >=0 <0.70.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7q9x-8g6p-3x75 (GitHub-reviewed advisory GHSA-7q9x-8g6p-3x75 lists affected ranges: npm @grackle-ai/server >=0 <=0.70.0)

Commands are suggestions: review each one before running it.

Loading voting…