Skip to content

← Actionable
Medium, CVSS 5.4

TYPO3 Cross-Site Scripting in Backend Modal Component

GHSA-7q33-hxwj-7p8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms 9.5.2, 8.7.21, 7.6.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms

    Affected
    >= 7.0.0, < 7.6.32>= 8.0.0, < 8.7.21>= 9.0.0, < 9.5.2
    Fixed in
    8.7.21, 9.5.2, 7.6.32

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Failing to properly encode user input, notifications shown in modal windows in the TYPO3 backend are vulnerable to cross-site scripting. A valid backend user account is needed in order to exploit this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7q33-hxwj-7p8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7q33-hxwj-7p8v

Advisory: TYPO3 Cross-Site Scripting in Backend Modal Component
IDs: GHSA-7q33-hxwj-7p8v
Record: https://patchnext.com/advisories/ghsa-7q33-hxwj-7p8v (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms 9.5.2, 8.7.21, 7.6.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms: affected >= 7.0.0, < 7.6.32; >= 8.0.0, < 8.7.21; >= 9.0.0, < 9.5.2; fixed in 8.7.21, 9.5.2, 7.6.32

## Suggested inspection (read-only)
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7q33-hxwj-7p8v (GitHub-reviewed advisory GHSA-7q33-hxwj-7p8v lists affected ranges: Packagist typo3/cms >=7.0.0 =8.0.0 =9.0.0 <9.5.2)

Commands are suggestions: review each one before running it.

Loading voting…