Server crash if running Python 3.10 w/ Sanic 20.12
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanic 20.12.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sanic
- Affected
- >= 0.1.7, < 20.12.6
- Fixed in
- 20.12.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7p79-6x2v-5h88 lists affected ranges: PyPI sanic >=0.1.7 <20.12.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7p79-6x2v-5h88 lists affected ranges: PyPI sanic >=0.1.7 <20.12.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
!!! ONLY APPLIES TO VERSIONS PRIOR TO Sanic v20.12 WHEN USING Python 3.10 !!! Sanic v20.12 officially supports Python versions 3.6, 3.7, 3.8, and 3.9. However, if you accidentally run it with version 3.10 (which is not supported by Sanic 20.12), your server is prone to crashing on an incoming web request. Impact Anyone running Sanic server between 0.1.7 and 20.12 using Python 3.10. Patches Sanic v20.12.6 Workarounds Use a supported version of Python (v3.6 - v3.9) References In asyncio, the explicit passing of a loop argument has been deprecated and will be removed in version 3.10 for the following: ... asyncio.Event Python 3.8 Release Notes For more information If you have any questions or comments about this advisory: Open an issue in the community forums Ping us on the Discord server
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7p79-6x2v-5h88
- Revision 1 · created ·
Published from osv record GHSA-7p79-6x2v-5h88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7p79-6x2v-5h88 Advisory: Server crash if running Python 3.10 w/ Sanic 20.12 IDs: GHSA-7p79-6x2v-5h88 Record: https://patchnext.com/advisories/ghsa-7p79-6x2v-5h88 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sanic 20.12.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sanic: affected >= 0.1.7, < 20.12.6; fixed in 20.12.6 ## Suggested inspection (read-only) - `python -m pip show sanic`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sanic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7p79-6x2v-5h88 (OSV record GHSA-7p79-6x2v-5h88 lists affected ranges: PyPI sanic >=0.1.7 <20.12.6 (fixed)) - Verified: https://github.com/advisories/GHSA-7p79-6x2v-5h88 (GitHub-reviewed advisory GHSA-7p79-6x2v-5h88 lists affected ranges: PyPI sanic >=0.1.7 <20.12.6) Commands are suggestions: review each one before running it.
Loading voting…