aiograpi has dependency on vulnerable orjson 3.11.4 (CVE-2025-67221)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiograpi 0.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI aiograpi
- Affected
- >= 0.6.6, < 0.7.2
- Fixed in
- 0.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7mw3-79jq-xc7f lists affected ranges: PyPI aiograpi >=0.6.6 <0.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mw3-79jq-xc7f lists affected ranges: PyPI aiograpi >=0.6.6 <0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact aiograpi 0.6.6 / 0.7.0 / 0.7.1 declared orjson==3.11.6 (and later ==3.11.8) in requirements.txt but setup.py carried a hard-coded duplicate requirements = [...] list that was never updated and still pinned orjson==3.11.4. When setuptools builds the source distribution it reads the metadata from setup.py, not from requirements.txt. So pip install aiograpi==0.6.6 (or 0.7.0 / 0.7.1) actually pulls orjson==3.11.4 — a version vulnerable to CVE-2025-67221 (stack overflow in orjson.dumps on deeply nested JSON inputs). Practical exploitability Low in the typical aiograpi flow: orjson is used to encode request bodies aiograpi itself constructs and to decode responses returned by Instagram. An attacker would need to coerce aiograpi to encode an attacker-controlled deeply-nested Python structure or to decode an attacker-supplied stream — not the normal call shape. However any caller doing client.publicrequest(...) or similar with caller-controlled payloads, or any caller passing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7mw3-79jq-xc7f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7mw3-79jq-xc7f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7mw3-79jq-xc7f Advisory: aiograpi has dependency on vulnerable orjson 3.11.4 (CVE-2025-67221) IDs: GHSA-7mw3-79jq-xc7f Record: https://patchnext.com/advisories/ghsa-7mw3-79jq-xc7f (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aiograpi 0.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI aiograpi: affected >= 0.6.6, < 0.7.2; fixed in 0.7.2 ## Suggested inspection (read-only) - `python -m pip show aiograpi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aiograpi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7mw3-79jq-xc7f (OSV record GHSA-7mw3-79jq-xc7f lists affected ranges: PyPI aiograpi >=0.6.6 <0.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7mw3-79jq-xc7f (GitHub-reviewed advisory GHSA-7mw3-79jq-xc7f lists affected ranges: PyPI aiograpi >=0.6.6 <0.7.2) Commands are suggestions: review each one before running it.
Loading voting…