Inconsistent storage layout for ERC2771ContextUpgradeable
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts-upgradeable 4.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @openzeppelin/contracts-upgradeable
- Affected
- >= 4.0.0, < 4.3.0
- Fixed in
- 4.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7j52-6fjp-58gr lists affected ranges: npm @openzeppelin/contracts-upgradeable >=4.0.0 <4.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7j52-6fjp-58gr lists affected ranges: npm @openzeppelin/contracts-upgradeable >=4.0.0 <4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The storage layout of the ERC2771ContextUpgradeable is not constant between versions. - versions 4.0.0, 4.1.0 and 4.2.0, the contract has a length of 51 slots. - since 4.3.0, the contract has a length of 50 slots - future versions will continue using 50 slots. This difference in layout could result in breaking upgrades if someone upgrades from an affected version to a non-affected version. It is thus recommended to be extremely careful when upgrading from a contract that uses ERC2771ContextUpgradeable <4.3.0 to a newer version that uses =4.3.0. We've assessed the instances of this contract found on chain (with publicly verified source code) and notified the corresponding teams of the risk that an upgrade could cause. Workarounds Potentially breaking upgrades would be caught by the OpenZeppelin Upgrades Plugins for Hardhat and Truffle. It is recommended to use this tooling for all your upgrades. If you need to upgrade to a newer version of the Upgradeable Contracts library, we…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7j52-6fjp-58gr
- Revision 1 · created ·
Published from osv record GHSA-7j52-6fjp-58gr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7j52-6fjp-58gr Advisory: Inconsistent storage layout for ERC2771ContextUpgradeable IDs: GHSA-7j52-6fjp-58gr Record: https://patchnext.com/advisories/ghsa-7j52-6fjp-58gr (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts-upgradeable 4.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @openzeppelin/contracts-upgradeable: affected >= 4.0.0, < 4.3.0; fixed in 4.3.0 ## Suggested inspection (read-only) - `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @openzeppelin/contracts-upgradeable. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7j52-6fjp-58gr (OSV record GHSA-7j52-6fjp-58gr lists affected ranges: npm @openzeppelin/contracts-upgradeable >=4.0.0 <4.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7j52-6fjp-58gr (GitHub-reviewed advisory GHSA-7j52-6fjp-58gr lists affected ranges: npm @openzeppelin/contracts-upgradeable >=4.0.0 <4.3.0) Commands are suggestions: review each one before running it.
Loading voting…