PocketMine-MP: Network amplification vulnerability with ActorEventPacket
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 5.39.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pocketmine/pocketmine-mp
- Affected
- < 5.39.2
- Fixed in
- 5.39.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hmv-4j2j-pp6f lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <5.39.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The server handles ActorEventPacket to trigger consuming animations from vanilla clients when they eat food or drink potions. This can be abused to make the server spam other clients, and to waste server CPU and memory. For every ActorEventPacket sent by the client, an animation event will be sent to every other player the attacker is visible to. This is similar to various other vulnerabilities which were fixed in the network overhaul of PM4 (e.g. AnimatePacket and LevelSoundEventPacket), but somehow this one slipped through the net. Patches The problem was addressed in aeea1150a772a005b92bd418366f1b7cf1a91ab5 by changing the mechanism for consuming animations to be fully controlled by the server. ActorEventPacket from the client is now discarded. Workarounds A plugin could use DataPacketDecodeEvent to rate-limit ActorEventPacket to prevent the attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7hmv-4j2j-pp6f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7hmv-4j2j-pp6f Advisory: PocketMine-MP: Network amplification vulnerability with `ActorEventPacket` IDs: GHSA-7hmv-4j2j-pp6f Record: https://patchnext.com/advisories/ghsa-7hmv-4j2j-pp6f (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 5.39.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pocketmine/pocketmine-mp: affected < 5.39.2; fixed in 5.39.2 ## Suggested inspection (read-only) - Packagist pocketmine/pocketmine-mp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pocketmine/pocketmine-mp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7hmv-4j2j-pp6f (GitHub-reviewed advisory GHSA-7hmv-4j2j-pp6f lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <5.39.2) Commands are suggestions: review each one before running it.
Loading voting…