Skip to content

← Actionable
Critical, CVSS 9.8

propel/propel1 SQL injection possible with limit() on MySQL

GHSA-7g7c-qhf3-x59p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (propel/propel1 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The limit() query method is susceptible to catastrophic SQL injection with MySQL. For example, given a model User for a table users: This will drop the users table! The cause appears to be a lack of integer casting of the limit input in either Criteria::setLimit() or in DBMySQL::applyLimit(). The code comments there seem to imply that casting was avoided due to overflow issues with 32-bit integers. This is surprising behavior since one of the primary purposes of an ORM is to prevent basic SQL injection. This affects all versions of Propel: 1.x, 2.x, and 3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7g7c-qhf3-x59p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7g7c-qhf3-x59p

Advisory: propel/propel1 SQL injection possible with limit() on MySQL
IDs: GHSA-7g7c-qhf3-x59p
Record: https://patchnext.com/advisories/ghsa-7g7c-qhf3-x59p (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: propel/propel1 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist propel/propel1: affected >= 1, <= 1.7.1; fixed in 1.7.2

## Suggested inspection (read-only)
- Packagist propel/propel1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on propel/propel1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7g7c-qhf3-x59p (GitHub-reviewed advisory GHSA-7g7c-qhf3-x59p lists affected ranges: Packagist propel/propel1 >=1 <=1.7.1)

Commands are suggestions: review each one before running it.

Loading voting…