OpenCC has an Out-of-bounds read when processing truncated UTF-8 input
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencc 1.2.0; opencc 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7fqq-q52p-2jjg lists affected ranges: npm opencc >=0 =0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7fqq-q52p-2jjg lists affected ranges: npm opencc >=0 =0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary OpenCC versions before 1.2.0 contain two CWE-125: Out-of-bounds Read issues caused by length validation failures in UTF-8 processing. When handling malformed or truncated UTF-8 input, OpenCC trusted derived length values without enforcing the invariant that processed length must not exceed the remaining input buffer. This could result in out-of-bounds reads during segmentation or conversion. Details Two independent code paths in OpenCC failed to enforce the invariant: matchedLength <= remainingLength Both paths assumed derived length values were valid and within input bounds, but did not validate that assumption against the remaining buffer. This created the following failure chain: invalid UTF-8 - incorrect derived length - incorrect pointer advance - remaining-length desynchronization - out-of-bounds read In MaxMatchSegmentation::Segment, this could desynchronize remaining-length tracking and cause out-of-bounds reads during prefix matching. In Conversion::Convert(const…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7fqq-q52p-2jjg
- Revision 1 · created ·
Published from osv record GHSA-7fqq-q52p-2jjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7fqq-q52p-2jjg Advisory: OpenCC has an Out-of-bounds read when processing truncated UTF-8 input IDs: GHSA-7fqq-q52p-2jjg Record: https://patchnext.com/advisories/ghsa-7fqq-q52p-2jjg (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opencc 1.2.0; opencc 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm opencc: affected < 1.2.0; fixed in 1.2.0 - PyPI opencc: affected < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `npm ls opencc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `python -m pip show opencc`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opencc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7fqq-q52p-2jjg (OSV record GHSA-7fqq-q52p-2jjg lists affected ranges: npm opencc >=0 =0 <1.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7fqq-q52p-2jjg (GitHub-reviewed advisory GHSA-7fqq-q52p-2jjg lists affected ranges: npm opencc >=0 =0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…