github-slug-action use of set-env Runner commands which are processed via stdout
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rlespinasse/github-slug-action 2.1.1, 1.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
GitHub Actions rlespinasse/github-slug-action
- Affected
- <= 1.1.0>= 2.0.0, <= 2.1.0
- Fixed in
- 1.1.1, 2.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7f32-hm4h-w77q lists affected ranges: GitHub Actions rlespinasse/github-slug-action >=0 =2.0.0 <=2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact This GitHub Action use set-env runner commands which are processed via stdout related to GHSA-mfwh-5m23-j46w Patches The following versions use the recommended Environment File Syntax. - 2.1.1 - 1.1.1 Workarounds None, it is strongly suggested that you upgrade as soon as possible. For more information If you have any questions or comments about this advisory: Open an issue in rlespinasse/github-slug-action
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7f32-hm4h-w77q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7f32-hm4h-w77q Advisory: github-slug-action use of `set-env` Runner commands which are processed via stdout IDs: GHSA-7f32-hm4h-w77q Record: https://patchnext.com/advisories/ghsa-7f32-hm4h-w77q (revision 1, source checked 26 Oct 2026, 17:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rlespinasse/github-slug-action 2.1.1, 1.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - GitHub Actions rlespinasse/github-slug-action: affected <= 1.1.0; >= 2.0.0, <= 2.1.0; fixed in 1.1.1, 2.1.1 ## Suggested inspection (read-only) - GitHub Actions rlespinasse/github-slug-action: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rlespinasse/github-slug-action. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7f32-hm4h-w77q (GitHub-reviewed advisory GHSA-7f32-hm4h-w77q lists affected ranges: GitHub Actions rlespinasse/github-slug-action >=0 =2.0.0 <=2.1.0) Commands are suggestions: review each one before running it.
Loading voting…