Skip to content

← Actionable
Medium, CVSS 5.3

Twig Path Traversal vulnerability in the filesystem loader

GHSA-7cvr-xhm5-x998

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 1.12.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist twig/twig

    Affected
    >= 1.0.0, < 1.12.3
    Fixed in
    1.12.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Twig is affected by path traversal vulnerability when used with TwigLoaderFilesystem for loading Twig templates but only if the application is using non-trusted template names (names provided by a end-user for instance). When affected, it is possible to go up one directory for the paths configured in the application's loader. For instance, if the filesystem loader is configured with /path/to/templates as a path to look for templates, an attacker can force Twig to include a file stored in /path/to by prepending the path with /../ like in {% include "/../somefileinpathto" %} Note that using anything else (like ../somefile, /../../somefile, or ../../somefile) won’t work and the application will return a proper exception.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7cvr-xhm5-x998

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7cvr-xhm5-x998

Advisory: Twig Path Traversal vulnerability in the filesystem loader
IDs: GHSA-7cvr-xhm5-x998
Record: https://patchnext.com/advisories/ghsa-7cvr-xhm5-x998 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twig/twig 1.12.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist twig/twig: affected >= 1.0.0, < 1.12.3; fixed in 1.12.3

## Suggested inspection (read-only)
- Packagist twig/twig: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twig/twig.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7cvr-xhm5-x998 (GitHub-reviewed advisory GHSA-7cvr-xhm5-x998 lists affected ranges: Packagist twig/twig >=1.0.0 <1.12.3)

Commands are suggestions: review each one before running it.

Loading voting…