Malware in pre-build binaries of bignum
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bignum 0.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm bignum
- Affected
- >= 0.12.2, < 0.13.1
- Fixed in
- 0.13.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7cgc-fjv4-52x6 lists affected ranges: npm bignum >=0.12.2 <0.13.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7cgc-fjv4-52x6 lists affected ranges: npm bignum >=0.12.2 <0.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact bignum releases from v0.12.2 to v0.13.0 (inclusive) used node-pre-gyp to optionally download pre-built binary versions of the addon. These binaries were published on a now-expired S3 bucket which has since been claimed by a malicious third party which is now serving binaries containing malware that exfiltrates data from the user's computer. Patches v0.13.1 does not use node-pre-gyp and does not have support for downloading pre-built binaries in any form, avoiding the risk of malicious downloads.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7cgc-fjv4-52x6
- Revision 1 · created ·
Published from osv record GHSA-7cgc-fjv4-52x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7cgc-fjv4-52x6 Advisory: Malware in pre-build binaries of bignum IDs: GHSA-7cgc-fjv4-52x6 Record: https://patchnext.com/advisories/ghsa-7cgc-fjv4-52x6 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bignum 0.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm bignum: affected >= 0.12.2, < 0.13.1; fixed in 0.13.1 ## Suggested inspection (read-only) - `npm ls bignum --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bignum. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7cgc-fjv4-52x6 (OSV record GHSA-7cgc-fjv4-52x6 lists affected ranges: npm bignum >=0.12.2 <0.13.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7cgc-fjv4-52x6 (GitHub-reviewed advisory GHSA-7cgc-fjv4-52x6 lists affected ranges: npm bignum >=0.12.2 <0.13.1) Commands are suggestions: review each one before running it.
Loading voting…