Skip to content

← Actionable
Medium, CVSS 6.8

Jujutsu does not have SHA-1 collision detection

GHSA-794x-2rpg-rfgr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jj-lib 0.28.1; jj-cli 0.28.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io jj-lib

    Affected
    < 0.28.1
    Fixed in
    0.28.1
  • crates.io jj-cli

    Affected
    < 0.28.1
    Fixed in
    0.28.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Jujutsu 0.28.0 and earlier rely on versions of gitoxide that use SHA-1 hash implementations without any collision detection, leaving them vulnerable to hash collision attacks. Details This is a result of the underlying CVE-2025-31130 / GHSA-2frx-2596-x5r6 vulnerability in the gitoxide library Jujutsu uses to interact with Git repositories; see that advisory for technical details. This separate advisory is being issued due to the downstream impact on users of Jujutsu. Impact An attacker with the ability to mount a collision attack on SHA-1 like the SHAttered or SHA-1 is a Shambles attacks could create two distinct Git objects with the same hash. This is becoming increasingly affordable for well‐resourced attackers, with the Shambles researchers in 2020 estimating $45k for a chosen‐prefix collision or $11k for a classical collision, and projecting less than $10k for a chosen‐prefix collision by 2025. The result could be used to disguise malicious repository contents, or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-794x-2rpg-rfgr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-794x-2rpg-rfgr

Advisory: Jujutsu does not have SHA-1 collision detection
IDs: GHSA-794x-2rpg-rfgr
Record: https://patchnext.com/advisories/ghsa-794x-2rpg-rfgr (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jj-lib 0.28.1; jj-cli 0.28.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io jj-lib: affected < 0.28.1; fixed in 0.28.1
- crates.io jj-cli: affected < 0.28.1; fixed in 0.28.1

## Suggested inspection (read-only)
- crates.io jj-lib: check the installed version with your package manager.
- crates.io jj-cli: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jj-lib, jj-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-794x-2rpg-rfgr (GitHub-reviewed advisory GHSA-794x-2rpg-rfgr lists affected ranges: crates.io jj-lib >=0 =0 <0.28.1)

Commands are suggestions: review each one before running it.

Loading voting…