Skip to content

← Actionable
Medium, CVSS 6.9

Craft Commerce: Partial Payment Amount Without Lower Bound Validation

GHSA-78vr-q6cf-c7p6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.6.5, 4.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/commerce

    Affected
    >= 5.0.0, <= 5.6.4>= 4.0.0, <= 4.11.1
    Fixed in
    4.11.2, 5.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The Order::setPaymentAmount() method accepts any float value without enforcing a minimum positive amount. The PaymentsController casts the user-supplied 'paymentAmount' parameter directly to float with no lower-bound check. Details When the store has 'Allow Partial Payment on Checkout' enabled, a user can submit a payment amount of $0.00 or even a negative value, potentially marking orders as paid without a valid transaction. <img width="690" height="80" alt="image" src="https://github.com/user-attachments/assets/78b653a6-ccae-4ce4-b71b-fc38a7757d73" / <img width="761" height="200" alt="image" src="https://github.com/user-attachments/assets/665a235f-62c2-45fe-aa41-c3f266881c77" / PoC Complete instructions, including specific configuration details, to reproduce the vulnerability. <img width="606" height="144" alt="image" src="https://github.com/user-attachments/assets/a04a6de2-7c5f-4837-aed6-58756e246b80" / Impact On stores with partial payment enabled, a customer may be able…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-78vr-q6cf-c7p6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-78vr-q6cf-c7p6

Advisory: Craft Commerce: Partial Payment Amount Without Lower Bound Validation
IDs: GHSA-78vr-q6cf-c7p6
Record: https://patchnext.com/advisories/ghsa-78vr-q6cf-c7p6 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.6.5, 4.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/commerce: affected >= 5.0.0, <= 5.6.4; >= 4.0.0, <= 4.11.1; fixed in 4.11.2, 5.6.5

## Suggested inspection (read-only)
- Packagist craftcms/commerce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/commerce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-78vr-q6cf-c7p6 (GitHub-reviewed advisory GHSA-78vr-q6cf-c7p6 lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0 <=4.11.1)

Commands are suggestions: review each one before running it.

Loading voting…