Skip to content

← Actionable
High, CVSS 7.3amended

@saltcorn/server Remote Code Execution (RCE) / SQL injection via prototype pollution by manipulating lang and defstring parameters when setting localizer strings

GHSA-78p3-fwcq-62c2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@saltcorn/server 1.0.0-beta.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The endpoint /site-structure/localizer/save-string/:lang/:defstring accepts two parameter values: lang and defstring. These values are used in an unsafe way to set the keys and value of the cfgStrings object. It allows to add/modify properties of the Object prototype that result in several logic issues, including: - RCE vulnerabilities by polluting the tempRootFolder property - SQL injection vulnerabilities by polluting the schema property when using PostgreSQL database. Details - file: https://github.com/saltcorn/saltcorn/blob/v1.0.0-beta.13/packages/server/routes/infoarch.js#L236-L239 PoC Setup: - set SALTCORNNWORKERS=1 before starting the saltcorn server (to easily observe the behavior of the PoC) - make sure to use PostgresSQL backend - login with a user with admin permission RCE This PoC demonstrates how to escalate the Prototype Pollution vulnerability to change the behavior of certain command executed. - check that the file that will be created does not exists: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-78p3-fwcq-62c2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-78p3-fwcq-62c2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-78p3-fwcq-62c2

Advisory: @saltcorn/server Remote Code Execution (RCE) / SQL injection via prototype pollution by manipulating `lang` and `defstring` parameters when setting localizer strings
IDs: GHSA-78p3-fwcq-62c2
Record: https://patchnext.com/advisories/ghsa-78p3-fwcq-62c2 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @saltcorn/server 1.0.0-beta.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @saltcorn/server: affected <= 1.0.0-beta.13; fixed in 1.0.0-beta.14

## Suggested inspection (read-only)
- `npm ls @saltcorn/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @saltcorn/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78p3-fwcq-62c2 (OSV record GHSA-78p3-fwcq-62c2 lists affected ranges: npm @saltcorn/server >=0 <1.0.0-beta.14 (fixed))
- Verified: https://github.com/advisories/GHSA-78p3-fwcq-62c2 (GitHub-reviewed advisory GHSA-78p3-fwcq-62c2 lists affected ranges: npm @saltcorn/server >=0 <=1.0.0-beta.13)

Commands are suggestions: review each one before running it.

Loading voting…