Skip to content

← Actionable
High, CVSS 8.1amended

Pillow: Bundled libopenjp2 2.5.4 in all wheels since 11.1.0 carries OSV-2025-219 heap-buffer-overflow write reachable from Image.open().load()

GHSA-78g4-xqwv-q3g8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pillow

    Affected
    >= 11.1.0, < 13.0.0
    Fixed in
    13.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Every Pillow wheel from 11.1.0 onward bundles a libopenjp2 containing a heap-buffer-overflow write that is fixed upstream on master but has never appeared in an OpenJPEG release. See https://osv.dev/vulnerability/OSV-2025-219 Because the wheel bundles its own copy, a patched host OS does not help. It is reachable from Image.open(fp); im.load() with default settings. I am reporting it here rather than only upstream because Pillow is where the vulnerable binary actually reaches users. Note the inversion that makes this easy to miss: OpenJPEG 2.5.2 and earlier are safe. The bug was introduced in 954c6e3c (2024-06-25), so keeping the dependency current is what creates the exposure. Details Affected wheels From .github/dependencies.json (openjpeg) at each tag: | Pillow | bundled OpenJPEG | status | |---|---|---| | 10.4.0 | 2.5.2 | safe | | 11.0.0 | 2.5.2 | safe | | 11.1.0, 11.2.1, 11.3.0 | 2.5.3 | affected | | 12.0.0 … 12.3.0 | 2.5.4 | affected | Confirmed on an installed wheel:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-78g4-xqwv-q3g8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-78g4-xqwv-q3g8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-78g4-xqwv-q3g8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-78g4-xqwv-q3g8

Advisory: Pillow: Bundled libopenjp2 2.5.4 in all wheels since 11.1.0 carries OSV-2025-219 heap-buffer-overflow write reachable from Image.open().load()
IDs: GHSA-78g4-xqwv-q3g8
Record: https://patchnext.com/advisories/ghsa-78g4-xqwv-q3g8 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pillow: affected >= 11.1.0, < 13.0.0; fixed in 13.0.0

## Suggested inspection (read-only)
- `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pillow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-78g4-xqwv-q3g8 (GitHub-reviewed advisory GHSA-78g4-xqwv-q3g8 lists affected ranges: PyPI pillow >=11.1.0 <13.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-78g4-xqwv-q3g8 (OSV record GHSA-78g4-xqwv-q3g8 lists affected ranges: PyPI pillow >=11.1.0 <13.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…