Silverstripe admin XSS Vulnerability via WYSIWYG editor
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/admin 1.1.1, 1.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/admin
- Affected
- >= 1.0.3, < 1.0.4>= 1.1.0, < 1.1.1
- Fixed in
- 1.0.4, 1.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-779c-7w4p-2c4g lists affected ranges: Packagist silverstripe/admin >=1.0.3 =1.1.0 <1.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
It is possible for a bad actor with access to the CMS to make use of onmouseover or onmouseout attributes in the WYSIWYG editor to embed malicious javascript.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-779c-7w4p-2c4g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-779c-7w4p-2c4g Advisory: Silverstripe admin XSS Vulnerability via WYSIWYG editor IDs: GHSA-779c-7w4p-2c4g Record: https://patchnext.com/advisories/ghsa-779c-7w4p-2c4g (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/admin 1.1.1, 1.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/admin: affected >= 1.0.3, < 1.0.4; >= 1.1.0, < 1.1.1; fixed in 1.0.4, 1.1.1 ## Suggested inspection (read-only) - Packagist silverstripe/admin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-779c-7w4p-2c4g (GitHub-reviewed advisory GHSA-779c-7w4p-2c4g lists affected ranges: Packagist silverstripe/admin >=1.0.3 =1.1.0 <1.1.1) Commands are suggestions: review each one before running it.
Loading voting…