Memory over-allocation in evm-core
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (evm-core 0.26.1, 0.25.1, 0.24.1, 0.23.1, 0.21.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io evm-core
- Affected
- >= 0.26.0, < 0.26.1>= 0.25.0, < 0.25.1>= 0.24.0, < 0.24.1>= 0.23.0, < 0.23.1< 0.21.1
- Fixed in
- 0.25.1, 0.24.1, 0.23.1, 0.26.1, 0.21.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-773q-5334-5gf9 lists affected ranges: crates.io evm-core >=0.26.0 =0.25.0 =0.24.0 =0.23.0 =0 <0.21.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Prior to the patch, when executing specific EVM opcodes related to memory operations that use evmcore::Memory::copylarge, the crate can over-allocate memory when it is not needed, making it possible for an attacker to perform denial-of-service attack. The flaw was corrected in commit 19ade85.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-773q-5334-5gf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-773q-5334-5gf9 Advisory: Memory over-allocation in evm-core IDs: GHSA-773q-5334-5gf9 Record: https://patchnext.com/advisories/ghsa-773q-5334-5gf9 (revision 1, source checked 26 Oct 2026, 15:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: evm-core 0.26.1, 0.25.1, 0.24.1, 0.23.1, 0.21.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io evm-core: affected >= 0.26.0, < 0.26.1; >= 0.25.0, < 0.25.1; >= 0.24.0, < 0.24.1; >= 0.23.0, < 0.23.1; < 0.21.1; fixed in 0.25.1, 0.24.1, 0.23.1, 0.26.1, 0.21.1 ## Suggested inspection (read-only) - crates.io evm-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on evm-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-773q-5334-5gf9 (GitHub-reviewed advisory GHSA-773q-5334-5gf9 lists affected ranges: crates.io evm-core >=0.26.0 =0.25.0 =0.24.0 =0.23.0 =0 <0.21.1) Commands are suggestions: review each one before running it.
Loading voting…