Skip to content

← Actionable
Medium, CVSS 6.1amended

Dosage Vulnerable to Stored Cross-Site Scripting (XSS) in HTML/RSS Output Handlers

GHSA-75mw-h36v-2jv7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dosage 3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dosage

    Affected
    <= 3.2
    Fixed in
    3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The HTML and RSS output handlers in dosagelib/events.py write user-controlled content (comic text and page URLs) directly into generated files without proper HTML escaping. When a user scrapes a malicious webcomic and opens the generated HTML/RSS file, attacker-controlled JavaScript can execute in their browser. CWE: CWE-79 - Improper Neutralization of Input During Web Page Generation (Cross-site Scripting) --- Details Vulnerable Code Locations The vulnerability exists in dosagelib/events.py where untrusted content is written to HTML/RSS output without escaping: 1. RSSEventHandler (lines 116-118) 2. HtmlEventHandler (lines 232, 238) Root Cause - BasicScraper.fetchText() in scraper.py:422 calls html.unescape() on extracted text - The output handlers never call html.escape() before writing to files - No sanitization of URLs or text content occurs anywhere in the output pipeline Data Flow --- PoC I created a proof-of-concept that demonstrates the vulnerability by simulating a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-75mw-h36v-2jv7

  2. Revision 1 · created ·

    Published from osv record GHSA-75mw-h36v-2jv7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-75mw-h36v-2jv7

Advisory: Dosage Vulnerable to Stored Cross-Site Scripting (XSS) in HTML/RSS Output Handlers
IDs: GHSA-75mw-h36v-2jv7
Record: https://patchnext.com/advisories/ghsa-75mw-h36v-2jv7 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dosage 3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dosage: affected <= 3.2; fixed in 3.3

## Suggested inspection (read-only)
- `python -m pip show dosage`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dosage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-75mw-h36v-2jv7 (OSV record GHSA-75mw-h36v-2jv7 lists affected ranges: PyPI dosage >=0 <3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-75mw-h36v-2jv7 (GitHub-reviewed advisory GHSA-75mw-h36v-2jv7 lists affected ranges: PyPI dosage >=0 <=3.2)

Commands are suggestions: review each one before running it.

Loading voting…